Python Program for Leap year

Total Blog Views: 59

Blog Status: publish

Created By: asad_fazlani Created at: 08-31-2021

Tags: python leap year using python

We add a Leap Day on February 29, almost every four years. The leap day is an extra, or intercalary day and we add it to the shortest month of the year, February.
In the Gregorian calendar three criteria must be taken into account to identify leap years:
  • The year can be evenly divided by 4, is a leap year, unless:
    • The year can be evenly divided by 100, it is NOT a leap year, unless:
      • The year is also evenly divisible by 400. Then it is a leap year.
This means that in the Gregorian calendar, the years 2000 and 2400 are leap years, while 1800, 1900, 2100, 2200, 2300 and 2500 are NOT leap years
 
 

 

Task
You are given the year, and you have to write a function to check if the year is leap or not.
Note that you have to complete the function and remaining code is given as template.
Output Format
Output is taken care of by the template. Your function must return a boolean value (True/False)
Sample Input  : 1990
Sample output : False
program : 

def is_leap(year):

    if year%4 ==0 and year%100 != 0:
        return True
    elif year%400 ==0:
        return True
    elif year%100 == 0:
        return False
    else:
        return False
 
year = int(input())
print(is_leap(year))
 
 
 


asad_fazlani

Technical Blogger at shadbox



Comments



  • vishnu | over 3 years ago
    Bravo!
  • asad | over 3 years ago
    Awesome
  • swazahmad | over 3 years ago
    Usefull information
Buy traffic for your website

About Shadbox

we have the “Get things executed” lifestyle at our place of work. There are not any excuses, no if’s or however’s in our dictionary. committed to navigating the ship of creativity to create cell answers, we resolve the real-lifestyles troubles of our clients and their clients. Our passion for work has won us many awards, year after 12 months.

Services

Downloads